DeltaV Setup
Reporting from DeltaV

Configuring DeltaV

XLReporter generates Excel based reports from
Emerson Process Management’s DeltaV from real time
data, historical archives as well as alarm and batch
history.

While there is no additional configuration for
XLReporter to connect to DeltaV, there are a few
settings that can be verified from within DeltaV. These
settings can be viewed and modified in the DeltaV
Explorer, which is accessible from the DeltaV program
group, under the Engineering folder.

The purpose of this document is to describe how to
interface XLReporter to DeltaV. This document covers
any initialization steps to DeltaV and troubleshooting
using tools provided by DeltaV.

Before you Begin

Check the OPC installation by selecting Applications,
Diagnostics from the menu which will open the
Diagnostics window. Expand the tree below the server
name in the left pane, and select OPC Subsystem.

In order for XLReporter to communicate with DeltaV,
the machine where XLReporter is installed must also
have the OPC core components installed. The OPC core
components are provided in the tools folder of the
XLReporter install CD or from
www.OPCFoundation.org.
If XLReporter is installed on a PC that is remote to
DeltaV then a number of settings need to be configured
on both the server and client machines. This includes
having matching Windows user accounts (with matching
passwords) on both machines and enabling DCOM on the
machine where DeltaV is installed.
For a detailed explanation of the requirements for remote
access, please read the OPC Training Institute document
OPC_and_DCOM_5_things_you_need_to_know that is
provided in the Tools folder of the XLReporter install
CD or from www.SyTech.com.

Process Values
XLReporter can take snapshots of the process values
and add them to an existing report worksheet, periodically
or on event. To prevent excessive build-up of information
in a single worksheet, new workbooks and worksheets
can be created automatically.
Process values can be retrieved from DeltaV by
XLReporter via the DeltaV OPC Server.

Diagnostics

Several variables appear in the upper right pane, one
being OInteg, which is the overall integrity of the OPC
server. This should have a value of GOOD.

Creating a Real Time Data Connector
To connect XLReporter to DeltaV via OPC, you will
first need to create a Connector. To do this, open
XLReporter’s Project Explorer, and open Connectors
from the Data tab. In Connectors, select Add, and select
Emerson Process Management, DeltaV Real-time
values.

If XLReporter is installed on a non-DeltaV node, the
DeltaV OPC Remote application needs to be installed on
the machine. This can be found on the DeltaV installation
CD in the DV_Extras folder.
Once installed, the DeltaV OPC server appears as a local
OPC server.

Under Primary Server, leave Node set to local.

Verifying the Real Time Data Connector
To verify the DeltaV real time interface, open
XLReporter’s Project Explorer. From the Tools tab
start the System Check application and select the
Connector tab. Select Add, choose your DeltaV real
time Connector from the dropdown list, and click the
pushbutton […] next to Items to open the Tag Browser
window.

Real Time System Check

Select one or more tags and verify that they update with
the current value using Start in the System Check
window.

Historical Data
With process data stored in a historian, the variety of
reports that can be produced by XLReporter increases
many fold.

Under Primary Server, if the server is on a remote
machine, set Node to the name of that machine, otherwise
leave it set to local.

Verifying the Historical Data Connector
In addition to sample values, informative metrics such as
run times and statistics are obtained by simply selecting
the tags and time frame of interest. e.g. hourly average,
maximum and minimum for each hour of the day.
XLReporter performs time-weighted calculations on the
historical data retrieved.

XLReporter accesses process values stored in the
historian using a connector group.
From XLReporter’s Project Explorer, under the Tools
tab, select Diagnostics, Connector Groups. Select the
DeltaV history connector and click Add.
Select the Type of group and click OK.

XLReporter can connect and retrieve data from both the
DeltaV Continuous Historian and the DeltaV Advanced
Continuous Historian via an OPCHDA connection.

Configuring DeltaV
While there is no additional configuration for
XLReporter to connect to DeltaV, there are a few
settings that can be verified from within DeltaV. These
settings can be viewed and modified in the DeltaV
Explorer, which is accessible from the DeltaV program
group, under the Engineering folder.

On the Columns tab, select the tag Name and
Calculation for each tag in the group.
On the Time Period tab, select the Start Time, End
Time and Interval for the group. By default this is set to
one hour intervals over the current day.
The Preview menu can be selected to preview the result
of the current configuration.

Preview

Preview displays the data exactly the same way it will be
written into the report
DeltaV Explorer

If using the Continuous Historian, check that the
Continuous Historian is enabled. This can be done by
right clicking the Continuous Historian icon in the left
pane, listed below the server name. Select Properties
and make sure that Enabled is checked.

Creating a Historical Data Connector
To connect XLReporter to DeltaV historical data you
will first need to create a Connector. To do this, open
XLReporter’s Project Explorer, and open Connectors
from the Data tab. In Connectors, select Add, and select
Emerson Process Management, DeltaV Continuous
Historian or DeltaV Advanced Continuous Historian.

Batch Historian Data

Event Chronicle Data

The DeltaV Batch Historian can be configured to log data
to a SQL Server database. XLReporter can retrieve data
from the database to use within reports.

The DeltaV Event Chronicle can be configured to log data
to text files (*.evt) on a per batch basis. XLReporter can
retrieve data from a specific file to use within reports.

Creating a Batch Historian Connector

Creating an Event Chronicle Connector

To connect XLReporter to the DeltaV Batch Historian
you will first need to create a Connector. To do this,
open XLReporter’s Project Explorer, and open
Connectors from the Data tab. In Connectors, select
Add, and select Emerson Process Management, DeltaV
Batch Historian.

To connect XLReporter to the DeltaV Event Chronicles
you will first need to create a Connector. To do this,
open XLReporter’s Project Explorer, and open
Connectors from the Data tab. In Connectors, select
Add, and select Emerson Process Management, DeltaV
Event Chronicle.

Under Primary Server, click the browse pushbutton […]
to connect to the database.
Select Microsoft SQL Server.
Set Server name to the SQL Server instance where the
DeltaV Batch Historian is configured.
Specify the Logon information and the Database within
the SQL Server instance where the Batch Historian data is
logged.
Click Test to verify the settings.

Verifying the Batch Historian Connector
XLReporter accesses Batch Historian data using a
connector group.
From XLReporter’s Project Explorer, under the Tools
tab, select Diagnostics, Connector Groups. Select the
Batch Historian connector and click Add.
On the Setup tab, under Database, set Table/View to a
table or view in the batch historian from which to retrieve
alarm data.

Under Source, for Folder, click the browse pushbutton
[…] and select the folder where the Event Chronicle files
are stored.

Verifying the Event Chronicle Connector
XLReporter accesses Event Chronicle data using a
connector group.

Once the table or view is selected, set Date Column to a
column with timestamps within the table or view.

From XLReporter’s Project Explorer, under the Tools
tab, select Diagnostics, Connector Groups. Select the
Batch Historian connector and click Add.

On the Columns tab, select the Columns for the Batch
Historian data you wish to retrieve.

On the Columns tab, select the Columns for the Event
Chronicle data you wish to retrieve.

On the Time Period tab, select the Start Time, End
Time and Interval for the group. By default this is set to
the first 60 values over the current day.

On the Filters tab, specify filtering to limit the type or
amount of alarms returned. You can filter based on any
available column.

On the Filters tab, specify filtering to limit the type or
amount of alarms returned. You can filter based on any
available column in the table or view selected.

The Event setting allows you to select one or more
specific events to return from the group. Click the browse
pushbutton […] and check any that apply. To see every
event, set every one unchecked.

The Preview menu can be selected to preview the result
of the current configuration.

The Preview menu can be selected to preview the result
of the current configuration. In the Preview window you
are prompted for a file name. Specify one of the .evt files
in the Source Folder specified in the connector.

Event Journal Data
The DeltaV Event Journal can be configured to log data to
a SQL Server database. XLReporter can retrieve data
from the database to use within reports.

Creating an Event Journal Connector
To connect XLReporter to the DeltaV Event Journal you
will first need to create a Connector. To do this, open
XLReporter’s Project Explorer, and open Connectors
from the Data tab. In Connectors, select Add, and select
Emerson Process Management, DeltaV Event Journal.
Under Primary Server, click the browse pushbutton […]
to connect to the database.

Select Microsoft SQL Server.
Set Server name to the SQL Server instance where the
DeltaV Event Journal is configured.
Specify the Logon information and the Database within
the SQL Server instance where the Event Journal data is
logged.
Click Test to verify the settings.
Under Table/Column, set the Table to Journal and the
Date Column to Date_Time.

Verifying the Event Journal Connector
XLReporter accesses Event Journal data using a
connector group.
From XLReporter’s Project Explorer, under the Tools
tab, select Diagnostics, Connector Groups. Select the
Event Journal connector and click Add.
On the Columns tab, select the Columns for the Event
Journal data you wish to retrieve.
On the Time Period tab, select the Start Time, End
Time and Interval for the group. By default this is set to
the first 60 values over the current day.

On the Filters tab, specify filtering to limit the type or
amount of alarms returned. You can filter based on any
available column in the table or view selected.
The Event Type setting allows you to select a specific
event types to retrieve data for. To retrieval all event
types, select Any otherwise select a specific type.
The Preview menu can be selected to preview the result
of the current configuration.

Analyze Data

Populating the Database

DeltaV Analyze can be used to generate Excel based
reports in a fixed format. XLReporter can extract the
data from these reports and export it to a database where
more sophisticated analysis can be performed producing
even more powerful reports.

The database will be populated at the frequency you
specified in the connector. To manually perform this,
from the Project Explorer, under the Project tab, select
Schedule, Designer.

Creating an Analyze Data Connector
To connect XLReporter to the DeltaV Analyze data you
will first need to create a Connector. To do this, open
XLReporter’s Project Explorer, and open Connectors
from the Data tab. In Connectors, select Add, and select
Emerson Process Management, DeltaV Analyze.
Under Consolidate to a Database, for Server, click the
browse pushbutton […] and connect to the database
where you would like the Analyze data to be stored.
Click Settings.

In the Schedule Designer select Tools, Script Editor.
The DV_export script will be listed. Select it and click
Test. The script will extract data from the files in the
folders configured.

Verifying the Analyze Connector
XLReporter accesses DeltaV Analyze data using a
database connector group.
From XLReporter’s Project Explorer, under the Tools
tab, select Diagnostics, Connector Groups. Select the
DeltaV Analyze connector and click Add. Set the Type
to Standard and click OK.
On the Setup tab, select the Table(s) or View(s) from
which to retrieve data.
On the Columns tab, select the Columns for the DeltaV
Analyze data you wish to retrieve.
On the Filters tab, specify filtering to limit the type or
amount of alarms returned. You can filter based on any
available column in the table or view selected.

Under the Folders tab, define each folder containing
DeltaV Analyze report files you wish to extract data from.

Under Labels define the Alarm Priority and Alarm
Rate labels if you have customized them in the DeltaV
Analyze application.
Under Schedule, determine the frequency at which data is
extracted from the DeltaV Analyze reports and stored in
the database.
On OK, the tables for the Analyze data are created in the
database specified.

The Preview menu can be selected to preview the result
of the current configuration.

Troubleshooting – Real Time Data

Troubleshooting – Historical Data

If you are experiencing issues connecting to the DeltaV
OPC Server or accessing real time values, DeltaV has
provided OPCWatchIt, as a diagnostic tool.

If you are experiencing issues connecting to the DeltaV
OPC-HDA Server or retrieving Historical data, DeltaV
has provided HDAprobe as a diagnostic tool.

To run, from a command line, enter opcwatchit.exe

To run, browse to C:\ DeltaV\bin or
C:\DeltaV\DVUtilities and double-click HDAprobe.exe.

OPC WatchIt Window

In the OPCWatchIt window, verify Server is set to
OPC.DeltaV.1. If it is not, click Change Server to select
it.
To choose tags, click BrowsePath. This opens the
Browse Attributes window showing a tree view of all
tags configured. Select a tag and click OK.
Click Read to display real time value of the selected tag.

DeltaV OPC HDA Probe

In the DeltaV OPC HDA Probe window, click Connect
Server and select DeltaV.OPCHDAsvr.1.
Click Add Items. This opens the Add HDA Items
window. Click Browse to open the OPC HDA Browse
window.
Click New Browser to view a list of tags. Select a tag
and click OK. That tag is now listed in the Add HDA
Items window. Click Add to add the tag and Done to
return to the main DeltaV OPC HDA Probe window.
Select the tag and click Read Raw to read the raw values
recorded for the selected tag. This opens the HDA Read
Raw window.
Click Set Start Time and Set End Time to specify the
time frame. By default time is in UTC (universal time).
Check local to convert to local time.
Click Read Raw. If this is successful, HR displays
Success.
To view the raw values, click View Values.

View OPC HDA Items

This opens the View OPC HDA Item window that
displays the historical data for the tag selected as well as a
graph. Click Done to close.
To retrieve processed values (e.g., averages, maximums,
minimums, etc.) follow the steps above but click Read
Processed rather than Read Raw.

